Ultimate Title Screens Resource

Resource Ultimate Title Screens Resource 2.0

GRMDevs

Filipino Dev
Member
Posts
24
#2
This is Actually very nice! I was actually planning to download both The Ultimate Title Screen and the Elite Battle System!
So glad that you now have the Universal Plugin Installer! The graphics are great! And the scripts are working perfectly!
I'm gonna include it in my Pokemon fan-game and definitely give credits!
 

GRMDevs

Filipino Dev
Member
Posts
24
#3
I'm actually having a problem. the animation is late so it doesn't go with the music. The music is fine while the animation is a bit laggy, what do you think the problem is? The music is faster than the animation, the animation is slow.
 
Last edited:

Luka S.J.

Wastage of Time
Member
Posts
79
#4
I'm actually having a problem. the animation is late so it doesn't go with the music. The music is fine while the animation is a bit laggy, what do you think the problem is? The music is faster than the animation, the animation is slow.
RMXP's engine is designed to cap out at a resolution of 640 x 480. As you can probably imagine, pushing it above that will result in performance drops. What you're doing, I'm assuming, is running the game at resolution scaling (through the options) larger than "M". This will yield significant drops in performance during some more resource intensive sprite transformations such as angles (which in the gen 6 style is pretty much the whole intro section or gen 7 the entire title screen). As a work around to that, I've disabled a lot of the animation in the title screens for the larger resolutions, but unless you want me to completely axe all the animations out of the scripts, you're going to have to deal with FPS drops when playing the game on larger resolutions. Nothing I can do about that. You're also going to notice performance drops throughout your entire game when playing on these upscaled resolutions. Framerate is completely fine on the "M" settings.

[P.S. This is also addressed in the FAQ. Please read the information I write. I certainly didn't do it for the fun of it]
 

Luka S.J.

Wastage of Time
Member
Posts
79
#6
The resolution of my game is 512 x 384, After, the UPI procedure, I played the Game.exe, and there.
Aside from criticising your hardware (lol) there isn't much I could do there. I get constant 40fps on all my test benches, and I don't have all the possible hardware to be able to test the stuff out in different scenarios. The video in the opening post also demonstrates that the title screen runs without problems. I'm still suspicious that you're playing the game on in-game settings larger than the "M" resolution.
 

GRMDevs

Filipino Dev
Member
Posts
24
#7
Other Screen Styles seems to work tho, only the XY Style is like that. I'll try figuring it out on my own, Thanks for the help.
 

Luka S.J.

Wastage of Time
Member
Posts
79
#8
Other Screen Styles seems to work tho, only the XY Style is like that. I'll try figuring it out on my own, Thanks for the help.
You still haven't really answered my question. I know exactly what is causing the frame drops; the angular transformations on the 'E' logo part.

Talking about these.
 

Luka S.J.

Wastage of Time
Member
Posts
79
#10
My screen size is "M", I checked it, I'm not really sure what to answer:joy:
Did you change the graphics of the 'E' part that pops in the intro, if so; how big is your graphic file? (this can also impact on the performance when applying angular transformations)
EDIT: Actually, this goes for more or less all of the graphics for that particular style.
 
Posts
19
#14
Luka S.J. submitted a new resource:

Ultimate Title Screens Resource - The best animated Title Screens for your fan-games!



Read more about this resource...
For some reason the Universal plug-n
Installer doesn't work.
It shows me the plug-ins I can install, but when I click install it gives me an error message.
If possible could you please put a download link for the ultimate title screens resources and scripts, so that if the universal plugin installer doesn't work, we can still use the resource?------------------------
Luka S.J. submitted a new resource:

Ultimate Title Screens Resource - The best animated Title Screens for your fan-games!



Read more about this resource...
For some reason the Universal plug-n
Installer doesn't work.
It shows me the plug-ins I can install, but when I click install it gives me an error message.

 
Posts
19
#16
Nope. Unless you want to make an actual bug report, and post the error you're getting ... I don't think I'm interested.
I'll post the error message as soon as I can.------------------------
Nope. Unless you want to make an actual bug report, and post the error you're getting ... I don't think I'm interested.
Here is the error:
Script 'File Handlers' line 239: Errno::EINVAL occurred
Invalid argument - //
 

Jamais

Novice
Member
Posts
11
#17
I'm having a really strange error, I think it's to do with the UPI. I'm probably just being stupid, but basically none of the resources do anything. I can open the UPI and install things, that all works fine, but it doesn't do anything in my game. The strangest thing is, right after I downloaded the UPI and some stuff off it, it all appeared in my game, the title screens and the fast forward mode, and it was great. But now none of it does anything. I probably did something and turned it off, or moved something around, I don't really know. Maybe the difference that stopped it from working was that I installed something that didn't work with my game?
 
Top