Elite Battle System: Gen 5 visual overhaul

Resource Elite Battle System: Gen 5 visual overhaul 4.4.9

Luka S.J.

Wastage of Time
Member
Posts
79
#2
So, I was really surprised that this issue has actually been present since the first ever release of EBS, and no one picked up on it. The indexes for the various sprites for Arceus' forms have been labelled incorrectly. The issue comes from the '???' type for which there are no graphics, yet the indexing kept progressing normally, which means that everything after the 8th form was shifted down by one. I've fixed that up, and uploaded the newly renamed sprites.
 

kelsey

Trainer
Member
Posts
60
#3
Hey Luka- I really love your system. I've been using it in my game for a couple of months now, and its pretty much worked perfectly. I did notice what I think is a bug today though- I used the debug option to level up a few of my pokemon in order to test out an event in my game, and I made one of them shiny with the debug because I saw it was an option. However, when I then went to battle with that pokemon later on, the in-battle graphic was messed up, like it was running a slideshow rather than one smooth animation. I opened the file and checked out the shiny back sprite for that pokemon, but it appears to be the same as the rest, so I have no idea what is going on. I then tested the same process with another pokemon and the same thing happened. Then I made all of the pokemon in the game shiny (altered the script so that 100% were), and caught a few pokemon and each of them had the same glitch, with the exception of two that were already in my party. Is this an issue with how the shiny back sprites line up in EBS, or have I messed something up? Here's a screenshot of what it looks like in game
 

Attachments

Luka S.J.

Wastage of Time
Member
Posts
79
#4
Hey Luka- I really love your system. I've been using it in my game for a couple of months now, and its pretty much worked perfectly. I did notice what I think is a bug today though- I used the debug option to level up a few of my pokemon in order to test out an event in my game, and I made one of them shiny with the debug because I saw it was an option. However, when I then went to battle with that pokemon later on, the in-battle graphic was messed up, like it was running a slideshow rather than one smooth animation. I opened the file and checked out the shiny back sprite for that pokemon, but it appears to be the same as the rest, so I have no idea what is going on. I then tested the same process with another pokemon and the same thing happened. Then I made all of the pokemon in the game shiny (altered the script so that 100% were), and caught a few pokemon and each of them had the same glitch, with the exception of two that were already in my party. Is this an issue with how the shiny back sprites line up in EBS, or have I messed something up? Here's a screenshot of what it looks like in game
I can't account for resources I haven't officially provided. The sprites you're using don't seem to have the proper formatting of the sprite reel, as per the instructions of this resource. Each individual frame in this spritesheet has to have their height be equal to their width (i.e. square); and each individual frame has to be ordered side by side and have the exact same dimensions. This is important as this determines the way their animation is rendered. Sorry, but I can't do anything about faulty 3rd party resources you are using.
 

kelsey

Trainer
Member
Posts
60
#5
I can't account for resources I haven't officially provided. The sprites you're using don't seem to have the proper formatting of the sprite reel, as per the instructions of this resource. Each individual frame in this spritesheet has to have their height be equal to their width (i.e. square); and each individual frame has to be ordered side by side and have the exact same dimensions. This is important as this determines the way their animation is rendered. Sorry, but I can't do anything about faulty 3rd party resources you are using.

**Edit** Ok, I installed a clean copy and everything works fine. I think the issue was that when I originally downloaded the system, I did it via third party somewhere and some of the sprites had been tampered with. I should have figured as much.... Anyway, great system. It makes the whole game so much more immersive.
 
Last edited:

Diverscope

Rookie
Member
Posts
8
#6
So I was working on the pokedex and tried to change the def "setSpeciesBitmap" in the Pokédex-Script to show the shadow version of a Pokémon. I tried to change the parameters of this method, but unfortunately it doesn't work.

This was the line that I changed (PScreen_Pokedex around line 302):

Code:
	@sprites["icon"].setSpeciesBitmap(species,(gender==1),form)
And I changed it into that:

Code:
	@sprites["icon"].setSpeciesBitmap(species,(gender==1),form,false,true)
In this case it would set the "shadow"-parameter to true.

I tried the same process on a clean Vanilla Essentials and there it works fine. Since EBS overwrites the def "setSpeciesBitmap", it somehow doesn't recognize its shadow-parameter. The same goes with "shiny". "back" on the other hand works perfectly fine.

I don't know if it's intended and there is another way to accomplish that or if it's just a bug. Anyway I wanted to let you know and maybe you have a solution for my problem?

I'm using EBS 1.3.2 and Pokémon Essentials V16.2.
 

Luka S.J.

Wastage of Time
Member
Posts
79
#7
So I was working on the pokedex and tried to change the def "setSpeciesBitmap" in the Pokédex-Script to show the shadow version of a Pokémon. I tried to change the parameters of this method, but unfortunately it doesn't work.

This was the line that I changed (PScreen_Pokedex around line 302):

Code:
	@sprites["icon"].setSpeciesBitmap(species,(gender==1),form)
And I changed it into that:

Code:
	@sprites["icon"].setSpeciesBitmap(species,(gender==1),form,false,true)
In this case it would set the "shadow"-parameter to true.

I tried the same process on a clean Vanilla Essentials and there it works fine. Since EBS overwrites the def "setSpeciesBitmap", it somehow doesn't recognize its shadow-parameter. The same goes with "shiny". "back" on the other hand works perfectly fine.

I don't know if it's intended and there is another way to accomplish that or if it's just a bug. Anyway I wanted to let you know and maybe you have a solution for my problem?

I'm using EBS 1.3.2 and Pokémon Essentials V16.2.
Since the stock Pokedex from vanilla Essentials gets broke, EBS includes a patch to fix this. And if you're applying your changes directly in the Pokedex script, they'll get overwritten. Check out line 338 in EliteBattle_BitmapWrapper for sauce; and delete the stuff you don't want.
 

ManlyMaid

Rookie
Member
Posts
1
#8
For some reason I suddenly get this error.
Tried it at a clean Essentials+Ebs but still get this error when the Rpg.Net.dll is inside the folder.
 

Luka S.J.

Wastage of Time
Member
Posts
79
#9
For some reason I suddenly get this error.
Tried it at a clean Essentials+Ebs but still get this error when the Rpg.Net.dll is inside the folder.
From the Rpg.Net.dll thread post:
Outside Source said:
Requires Microsoft .NET Framework 3.5
Your system probably doesn't have the .NET Framework installed on it. I'd recommend doing a quick google search for the official download from one from Microsoft (versions 4.0 and above work as well from my experience).
 

Pokesage101

Rookie
Member
Posts
1
#10
Hey,
I am really enjoying your system! I am developing a Fan-Game. In the your rules section it states this:
• You may not use footage of this resource (unless you're showcasing modifications done to it) in order to promote your game
Does that mean that if I include this in my game I cannot include any battle footage in my trailer for my game? By the way I know to give credit.
 

Luka S.J.

Wastage of Time
Member
Posts
79
#11
Hey,
I am really enjoying your system! I am developing a Fan-Game. In the your rules section it states this:
• You may not use footage of this resource (unless you're showcasing modifications done to it) in order to promote your game
Does that mean that if I include this in my game I cannot include any battle footage in my trailer for my game? By the way I know to give credit.
There is no skill involved in double clicking on an installer. Everybody knows what EBS looks like at this point. I'm trying to promote some originality. No, I don't want to see another trailer that is 80% just showing stock EBS. It's a trailer for your game, show the stuff you made. If you want to let people know you're using EBS, you can simply just put it in a "features" list in your game's thread/page.
 
Last edited:

Yankas

Rookie
Member
Posts
1
#14
While using your system, I did notice that the battle systems' UI is never deposed and the sprites linger after battle. This never becomes apparent, because the elements are positioned off-screen, so I didn't even notice until I started messing around with the resolution. I wanted to make sure if this behavior is intentional and I should just them off-screen when re-positioning the UI for the new resolution or if it was intended for them to be deposed.
 
Last edited:

Luka S.J.

Wastage of Time
Member
Posts
79
#15
While using your system, I did notice that the battle systems' UI is never deposed and the sprites linger after battle. This never becomes apparent, because the elements are positioned off-screen, so I didn't even notice until I started messing around with the resolution. I wanted to make sure if this behavior is intentional and I should just them off-screen when re-positioning the UI for the new resolution or if it was intended for them to be deposed.
Nah, that's just an oversight on my end. I still have to make adjustments to the Bag UI to have it position/scale properly on different screen sizes - which is something that I'll be publishing with the next update. I'll post here once I've finished everything I want for the next update. This update will be exclusive for the new UPI though.
 

TheLightSword

does anyone read this?
Member
Posts
136
#16
is there a way to put in one custom move animation from the animation editor instead the default animation for each type?
b'cause i'm adding in lots of new moves and most of them don't go well with the default animations.
 

Luka S.J.

Wastage of Time
Member
Posts
79
#17
is there a way to put in one custom move animation from the animation editor instead the default animation for each type?
b'cause i'm adding in lots of new moves and most of them don't go well with the default animations.
First of all, go ahead and set REPLACEMISSINGANIM in your settings to true; which will prevent EBS from bypassing Animation Editor made animations in the first place. As for what else to do, that is an Essentials matter. Essentials by default assigns global (type specific) move animations. This you will have to edit in def pbFindAnimation, more specifically the part that looks like this
Code:
      typedefaultanim=[[:NORMAL,:TACKLE],
                       [:FIGHTING,:COMETPUNCH],
                       [:FLYING,:GUST],
                       [:POISON,:SLUDGE],
                       [:GROUND,:MUDSLAP],
                       [:ROCK,:ROCKTHROW],
                       [:BUG,:TWINEEDLE],
                       [:GHOST,:NIGHTSHADE],
                       [:STEEL,:GYROBALL],
                       [:FIRE,:EMBER],
                       [:WATER,:WATERGUN],
                       [:GRASS,:RAZORLEAF],
                       [:ELECTRIC,:THUNDERSHOCK],
                       [:PSYCHIC,:CONFUSION],
                       [:ICE,:ICEBALL],
                       [:DRAGON,:DRAGONRAGE],
                       [:DARK,:PURSUIT],
                       [:FAIRY,:FAIRYWIND]]
 

Luka S.J.

Wastage of Time
Member
Posts
79
#18
Luka S.J. updated Elite Battle System: Gen 5 visual overhaul with a new update entry:

Sun & Moon VS Sequences

For those of you who may not keep up to date with my day-to-day relationship with the public resources I publish, I wanted to make an announcement. So I've been re-working the way Sun & Moon styled VS sequences in EBS get handled, and in the meantime I've decided to add on a bunch of new animations. This update is only available through the UPI (v2). If you're interested in how to use those, there is a tutorial fresh out of the...
Read the rest of this update entry...
 
Posts
25
#20
So basically I don't want the animated Elite Battle System Pokemon Sprites, but I still want all of the other cool stuff that comes with EBS.I was wondering if anybody had collected static sprites that are scaled proportionally to EBS. I know I could do this myself, but I just wanted to see if anyone had done this before I go and do all of the Pokemon. You might be wondering why I would want to do this, it is because nobody has animated 6-7 sprites and creating new fakemon sprites that are animated is out of my skill level. Just to make my game look a little more clean I don't want to have static and animated sprites at the same time (because in my opinion that looks bad). Thanks for any help.
 
Top