v17 Help with error when starting game

This thread pertains to v17 of Pokémon Essentials.

Sumit pathak

Rookie
Member
Joined
Sep 21, 2022
Posts
4
Age
19
Hey! Can anyone tell me how to resolve this error? This is when I try to change the intro BGM. Thank you!
 

Attachments

  • IMG20220921173202.jpg
    IMG20220921173202.jpg
    1.4 MB · Views: 16
I'm guessing you changed pbBGMPlay(data_system.title_bgm) to pbBGMPlay(Title_Oringin)? You need quotes around the filename - pbBGMPlay("Title_Oringin"). (data_system.title_bgm is a variable, not a string, so that's why it can be put in without them)

But there's not really any reason why you'd need to edit the scripts to do this - the game just looks for any BGM file named "Title", so rather than edit the script, you could just rename your file Title and leave the script as it is.

Are you particularly far in development? Because v17 is pretty old, I'd strongly recommend working with the latest version of Essentials instead.

Also, the PrtScn key takes a screencap, it's easier to share and look at than a photo of a monitor.
 

Sumit pathak

Rookie
Member
Joined
Sep 21, 2022
Posts
4
Age
19
I'm guessing you changed pbBGMPlay(data_system.title_bgm) to pbBGMPlay(Title_Oringin)? You need quotes around the filename - pbBGMPlay("Title_Oringin"). (data_system.title_bgm is a variable, not a string, so that's why it can be put in without them)

But there's not really any reason why you'd need to edit the scripts to do this - the game just looks for any BGM file named "Title", so rather than edit the script, you could just rename your file Title and leave the script as it is.

Are you particularly far in development? Because v17 is pretty old, I'd strongly recommend working with the latest version of Essentials instead.

Also, the PrtScn key takes a screencap, it's easier to share and look at than a photo of a monitor.
Thank you so much... Sir.. ❤️❤️
 

You’ll likely need to upgrade through each vers, though- so go from v17 to v18, then to v19, then to v20. (you can find downloads for them all on Luka’s website)

Maruno’s also mentioned that it’s sometimes easier to skip porting old PBS files and just make your changes in the latest ones, since there’s some flags and stuff that were added in later versions.
 

Sumit pathak

Rookie
Member
Joined
Sep 21, 2022
Posts
4
Age
19
O..

You’ll likely need to upgrade through each vers, though- so go from v17 to v18, then to v19, then to v20. (you can find downloads for them all on Luka’s website)

Maruno’s also mentioned that it’s sometimes easier to skip porting old PBS files and just make your changes in the latest ones, since there’s some flags and stuff that were added in later versions.
And can you plez me that to how to we erase or events or end them after use..
 
Top