v18 I recently got those errors, and i practically can't playtest.

This thread pertains to v18 of Pokémon Essentials.

Alep2007

local weirdo
Member
Joined
Oct 21, 2020
Posts
46
Age
14
error 1:
---------------------------
Error
---------------------------
Script '[PField_Encounters]' line 176: NoMethodError occurred.

undefined method `isDesert?' for PBTerrain:Module

from 'PField_Encounters' line 176 in `pbEncounterType'
from 'PField_Field' line 381 in `pbBattleOnStepTaken'
from 'PField_Field' line 376
from 'PField_Field' line 374 in `call'
from 'Event_Handlers' line 51 in `trigger'
from 'Event_Handlers' line 46 in `each'
from 'Event_Handlers' line 46 in `trigger'
from 'Game_Player' line 135 in `turnGeneric'
from 'Game_Character' line 708 in `turn_down'
from 'Game_Player' line 400 in `update_command_new'
from 'Game_Character' line 795 in `update_command'
from 'Game_Player_Visuals' line 67 in `update_command'
---------------------------
This appears practically at every step I take. This started after I saw Thundaga's new encounter types and followed it perfectly.

error 2 and 3:
This appears at every wild battle:

---------------------------
Error
---------------------------
Script '[Scene_Initialize]' line 185: ArgumentError occurred.

wrong number of arguments(4 for 3)

from 'Scene_Initialize' line 185 in `initialize'
from 'Scene_Initialize' line 185 in `new'
from 'Scene_Initialize' line 185 in `pbCreatePokemonSprite'
from 'Scene_Initialize' line 80 in `_bugContest_pbInitSprites'
from 'Scene_Initialize' line 77 in `each_with_index'
from 'Scene_Initialize' line 77 in `each'
from 'Scene_Initialize' line 77 in `each_with_index'
from 'Scene_Initialize' line 77 in `_bugContest_pbInitSprites'
from 'PokeBattle_BugContest' line 8 in `pbInitSprites'
from 'Scene_Initialize' line 21 in `pbStartBattle'
from 'Battle_StartAndEnd' line 270 in `pbStartBattleCore'
from 'Battle_StartAndEnd' line 258 in `pbStartBattle'
---------------------------
OK
---------------------------

This happens at every trainer battle:

---------------------------
Error
---------------------------
Script '[Debug_Menu]' line 369: NoMethodError occurred.

undefined method `pbTrainerBattle' for #<PokemonPauseMenu:0xd3aacc8>

from 'Debug_Menu' line 369 in `__errorTiles__pbDebugMenuActions'
from 'deleting unvalid tiles' line 17 in `pbDebugMenuActions'
from 'Debug_Menu' line 857 in `pbDebugMenu'
from 'Debug_Menu' line 821 in `loop'
from 'Debug_Menu' line 859 in `pbDebugMenu'
from 'PScreen_PauseMenu' line 258 in `pbStartPokemonMenu'
from 'PScreen_PauseMenu' line 257 in `pbFadeOutIn'
from 'PScreen_PauseMenu' line 260 in `pbStartPokemonMenu'
from 'PScreen_PauseMenu' line 146 in `loop'
from 'PScreen_PauseMenu' line 278 in `pbStartPokemonMenu'
from 'Scene_Map' line 107 in `call_menu'
from 'Scene_Map' line 206 in `update'
---------------------------
OK
---------------------------

Error 4:
This happens when I open the Kanto dex:

---------------------------
Error
---------------------------
Script '[PScreen_PokedexMain]' line 25: NoMethodError occurred.

undefined method `[]' for nil:NilClass

from 'PScreen_PokedexMain' line 25 in `species'
from 'PScreen_PokedexMain' line 387 in `pbRefresh'
from 'PScreen_PokedexMain' line 379 in `pbRefreshDexList'
from 'PScreen_PokedexMain' line 260 in `pbStartScene'
from 'PScreen_PokedexMain' line 1186 in `pbStartScreen'
from 'PScreen_PokedexMenu' line 121 in `pbStartScreen'
from 'PScreen_PokedexMenu' line 118 in `pbFadeOutIn'
from 'PScreen_PokedexMenu' line 122 in `pbStartScreen'
from 'PScreen_PokedexMenu' line 113 in `loop'
from 'PScreen_PokedexMenu' line 123 in `pbStartScreen'
from 'PScreen_PauseMenu' line 170 in `pbStartPokemonMenu'
from 'PScreen_PauseMenu' line 167 in `pbFadeOutIn'
---------------------------
OK
---------------------------
 

Alep2007

local weirdo
Member
Joined
Oct 21, 2020
Posts
46
Age
14

TechSkylander1518

Wiki Dweeb
Member
Joined
Mar 24, 2017
Posts
487
1st, the first qoute here I don't know how to remove it. 2nd, I added some autotiles, nothing more
To remove quotes, you just highlight them and press backspace, same as you would any other text.

What terrain tag did you put on the autotiles? And are you getting this error on a certain map? That would definitely help narrow down the problem.
 

Alep2007

local weirdo
Member
Joined
Oct 21, 2020
Posts
46
Age
14
To remove quotes, you just highlight them and press backspace, same as you would any other text.

What terrain tag did you put on the autotiles? And are you getting this error on a certain map? That would definitely help narrow down the problem.
the tiles are ricolors of gen 1 waters, so they have the 7 tag. the error appears afeter I load the save file, so I don't know
 

TechSkylander1518

Wiki Dweeb
Member
Joined
Mar 24, 2017
Posts
487
I did it, but people here can't just say "oh, you didn't put this part", no, "Are you sure you pasted everything? check if you pasted everything"
Because we're not going to be able to immediately tell "Oh, if you're getting this error, then it's because you're missing this specific line of text," and without seeing the code of your game themselves, they can't look and see what you did differently. All anyone can do is just tell you to follow the steps they give.
 

Alep2007

local weirdo
Member
Joined
Oct 21, 2020
Posts
46
Age
14
Because we're not going to be able to immediately tell "Oh, if you're getting this error, then it's because you're missing this specific line of text," and without seeing the code of your game themselves, they can't look and see what you did differently. All anyone can do is just tell you to follow the steps they give.
the error is specifically saying that I'm missing a part of text. Sorry for the rant, tho
 
Top