Help Player invisble.

Karpy

NinjaFish Legion!
Member
Posts
20
#1
so my game kept saying an error that there were missing stuff in the PBS files, so i replaced them all with the normal essentials PBS's (i didnt alter the PBS files before the error). now when i start the game my players invisible.
ive checked:
* the tilesets (priority and pass through ability)
* the player sprites
* the debug options
and i cant move either (unless i used Ctrl button in debug to go thru stuff)
 
Last edited:

Poq

Trainer
Member
Posts
58
#2
Have you tried starting a new game? If you're loading from a save, the intro choices you made (which determine your sprite) are now pointing to the contents of documents that have changed, so they can get wonky.
 

Mr. Gela

Elite Trainer
Member
Posts
140
#3
Check metadata.txt. If replacing the PBS files made the player graphic-less, it's probably because the filenames for their sprites are in the PBS files.
 

Karpy

NinjaFish Legion!
Member
Posts
20
#4
Have you tried starting a new game? If you're loading from a save, the intro choices you made (which determine your sprite) are now pointing to the contents of documents that have changed, so they can get wonky.
when i press new game it does it. cause ive made and auto-chosen gender and name. and dont have any save files
 

Poq

Trainer
Member
Posts
58
#5
when i press new game it does it. cause ive made and auto-chosen gender and name. and dont have any save files
Gotcha. Then you'll definitely want to follow up with what Mr. Gela posted. Check the spots where those sprites are assigned. Maybe check your intro event too to make sure that the auto-selected steps are still assigning a file for the sprite.
 

Karpy

NinjaFish Legion!
Member
Posts
20
#6
Check metadata.txt. If replacing the PBS files made the player graphic-less, it's probably because the filenames for their sprites are in the PBS files.
k i fixed it. the player is visible now but cant move (it can only move while in "tall grass".)
 

kmb

dabbling in game design
Member
Posts
61
#7
That sounds like a tile map error. I would suggest you edit the passability of some of the tiles.

My guess is your RMXP crashed while you were working on a game, and you didn't get a chance to save. For some reason, that can mess a lot of things up. The best option is to copy / paste unmodified data files from an older project. This usually fixes the problem.
 
Top