Help Maps won't stay connected...

kmb

dabbling in game design
Member
Posts
61
#1
My maps will only connect three at a time it seems. If I try to connect more and run the game, it appears to erase a random map connection and make the player walk into blank space. There may be something in the PBS file I'm not tweaking. My guess is it's sharing data with another PBS file that says the map connection is supposed to go somewhere else. I wish I knew a quick way to fix this.

A temporary fix would be to just be sure to warp the character during map transfers, and rather than making it open world, put the character on a closed map. Those are things I can do, but I would still like to get to the bottom of this. It's annoying to have half of your map missing after rebooting the project.
 
Last edited:

Karpy

NinjaFish Legion!
Member
Posts
20
#2
try putting the 4th map somewhere else and at the 3rd put a "transfer player" event.
thats the only way i know right now
 

kmb

dabbling in game design
Member
Posts
61
#4
I think I'll try something. For reference, though, is it supposed to do that, or should I be able to connect all of the maps I want?
 

Mr. Gela

Elite Trainer
Member
Posts
140
#5
I think I'll try something. For reference, though, is it supposed to do that, or should I be able to connect all of the maps I want?
Can you post a screenshot of how the maps are connected? That small preview in the editor with the maps zoomed out will do.
 

kmb

dabbling in game design
Member
Posts
61
#6
I can do that, but what happens usually is I save the game, try to play it again, and the map connections I set aren't there. Let me try a few things, take some screenshots, and report the results.
 
Top